Internet Protocol version 6 (IPv6) is a version of the Internet Protocol (IP) that is designed to succeed Internet Protocol version 4 (IPv4). The Internet operates by transferring data in small packets that are independently routed across networks as specified by an international communications protocol known as the Internet Protocol. Each data packet contains two numeric addresses that are the packet's origin and destination devices.
Before We Go to IPv6 Command Reference we’ll See First What Ipv6 and How to Configure Ipv6 on CISCO Router.
We are slowly approaching the implementation of IPv6 in a mass scale and thus we must be ready to learn some significant differences over IPv4. Also, some IP addressing terms will start to appear with increasing frequency in our day to day work. So let’s see some notable concepts that you need to know about IPv6.
- IPv6 addresses are 128 bits long and are expressed in hexadecimal numbers.
- IPv4 addresses are 32 bits long and are represented as four octets separated by periods. Each octet of the address is represented in decimal, taking a possible value between 0 and 255.
For IPv6, the 128-bit address is divided along 16-bit boundaries, and each 16-bit block is converted to a 4-digit hexadecimal number and separated by colons. The resulting representation is called colon hexadecimal.
The following is an IPv6 address in binary form:
00100001110110100000000011010011000000000000000000101111001110110000001010101010000000001111111111111110001010001001110001011010
The 128-bit address is divided along 16-bit boundaries:
0010000111011010 0000000011010011 0000000000000000 00101111001110110000001010101010 0000000011111111 1111111000101000 1001110001011010
Each 16-bit block is converted to hexadecimal and delimited with colons. The result is:
21DA:00D3:0000:2F3B:02AA:00FF:FE28:9C5A
IPv6 address representation is further simplified by suppressing the leading zeros within each 16-bit block. However, each block must have at least a single digit. With
leading zero suppression, the result is:
21DA:D3:0:2F3B:2AA:FF:FE28:9C5A
BASICS IPV6 CONFIGURATION:
LAB Description: WE HAVE TWO ROUTERS A & ROUTER B AND This Lab Exercise Demonstrates Testing The Connectivity Using Ping Between Two Routers (ROUTERS A & ROUTER B) Configured With RIP Routing Processes With IPV6.
ROUTER A:
ROUTER A>enable
ROUTER A #configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
ROUTER A(config)#ipv6 unicast-routing
ROUTER A(config)#interface serial 0
ROUTER A(config-if)# ipv6 enable
ROUTER A(config-if)#ipv6 address 2001:3abc:d00:4ab:2::1/64
ROUTER A(config-if)#ipv6 rip process1 enable
ROUTER A(config-if)#no shutdown
ROUTER A(config-if)#exit
ROUTER A(config)#exit
ROUTER A#copy running-config startup-config
ROUTER A#
NOW ON ROUTER B:
ROUTER B>enable
ROUTER B #configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
ROUTER B(config)#ipv6 unicast-routing
ROUTER B(config)#interface serial 0
ROUTER B(config-if)# ipv6 enable
ROUTER B(config-if)#ipv6 address 2001:3abc:d00:4ab:2::2/64
ROUTER B(config-if)#ipv6 rip process1 enable
ROUTER B(config-if)#no shutdown
ROUTER B(config-if)#exit
ROUTER B(config)#exit
ROUTER B#copy running-config startup-config
ROUTER B#ping ipv6 2001:3abc:d00:4ab:2::1/64
NOW WE ARE GOING TO SEE THE IPv6 CISCO IOS COMMAND.
CISCO IPV6 CONFIGURATION COMMANDS:
BASIC IPv6 COMMANDS:
To enable routing of IPv6 packets – required to enable IPv6 on a router:
Router(config)# ipv6 unicast-routing
To enable IPv6 on an interface:
Router(config-if)# ipv6 enable
To add an IPv6 address to an interface:
ipv6 address / [link-local] [eui-64]
To leave the interface unnumbered:
ipv6 unnumbered eth 0/0
IPV6 ENABLED COMMANDS:
ping ipv6
traceroute ipv6
telnet
ssh [-l ] [-c ] [-o numberofpasswdprompts <#>] [-p ] [command] show ip ssh
ip http server
dns lookup
tftp
NEIGHBOR DISCOVERY:
To adjust the Router Advertisement intervals:
ipv6 nc reachable-time <#>
ipv6 nd ra-interval <#> default is 200 seconds
ipv6 nd ra-lifetime <#> default is 1800 seconds (30 minutes)
ipv6 nd ns-interval <#> default is 1000 milliseconds
ipv6 nd suppress-ra
ipv6 nd managed-config-flag
ipv6 nd other-config-flag
TO ADJUST THE LIFETIMES FOR THE PREFIX:
ipv6 nd prefix-advertisement / [onlink] [auto-config]
ipv6 nd prefix-advertisement FEC0::C0A8:20C0/123 0 0 autoconfig
Valid lifetime = how long the node’s address remains in the valid state – after that it is invalid
Preferred lifetime = how long the stateless autoconfig address remains preferred – less than or equal to the valid lifetime - If preferred-lifetime = 0 then this router is not preferred
Off-link = sets the L-bit to OFF – default setting is to have the L-bit set to ON
No-autoconifg = sets the A-bit to OFF – default setting is to have the A-bit set to ON
No-advertise = the specified prefix cannot be used for stateless autoconfiguration – the prefix is not included in RA messages – default is to have this flag turned OFF
To remove an advertised prefix:
no ipv6 nd prefix
To turn off Router Advertisements:
no suppress-ra
Duplicate Address Detection (DAD):
ipv6 nd dad attempts <#> disabled with a setting of “0”
Router Redirection:
ipv6 redirects
ipv6 icmp error-interval msec
OTHER COMMANDS:
ip domain lookup
ip name-server
ipv6 neighbor Ethernet 0
BASIC IPv6 SHOW COMMANDS:
show ipv6 ?
show ipv6 interface [prefix]
show interface
show ipv6 neighbors [ | ]
show ipv6 mtu
show ipv6 protocols
show ipv6 interface [brief]
show ipv6 traffic
show ipv6 route
show ipv6 routers
show bgp
show bgp summary
show bgp ipv6 unicast neighbor routes show bgp ipv6 unicast neighbor advertised
BASIC IPv6 DEBUG COMMANDS:
debug ipv6 ?
debug ipv6 packet
debug ipv6 icmp
debug ipv6 nd
ping ipv6
traceroute ipv6
clear ipv6 ?
clear ipv6 neighbors
CISCO EXPRESS FORWARDING:
ipv6 cef
ipv6 cef distributed
show ipv6 cef . . .
show cef
debug ipv6 cef [drops | events | hash | receive | table]
ROUTING COMMANDS:
show ipv6 route [connected | local | static | rip | bgp | isis | ospf]
RIPng:
To enable RIPng:
Router(config)# ipv6 router rip <TAG>
To enable RIPng on an interface:
Router(config-if)# ipv6 rip <TAG> enable
To originate the default router (::/0) out an interface:
Router(config-if)# ipv6 rip <TAG> default-information originate
Router(config-rtr)# distance <#>
Router(config-rtr)# distribute-list prefix-list [in | out] Router(config-rtr)# metric-offset <#>
Router(config-rtr)# poison-reverse
Router(config-rtr)# split-horizon
Router(config-rtr)# port multicast-group
Router(config-rtr)# timers
Router(config-rtr)# redistribute [ connected | isis | ospf | static | bgp | rip <TAG> ] [metric ] [level-1 | level-1-2 | level-2] [route-map ]
RIPng Show Commands:
show ipv6 route
show ipv6 rip [database] [next-hops]
show ipv6 protocols
RIPng Debug Commands:
debug ipv6 rip
debug ipv6 routing
clear ipv6 rip <TAG>
OSPF vs IPV6:
The "area range" command is a Cisco IOS "Router" configuration command; that is used to consolidate and summarize routes at an OSPF area boundary.
Another way of explaining is, the "area range" command is a Cisco IOS "Router" configuration command; that is performed (used) only on OSPF Area Border Routers or (ABRs), so the ABRs can perform "route summarization" for an OSPF area.
Now, just in case you're new to the concept of an ABR performing "Route Summarization"; ABR "Route Summarization" is the process in which an OSPF Area Border Router (ABR) advertises a single summarized route to another External ABR; and the single summarized route that is advertised by the ABR, represents the address range of the particular OSPF area(s) that the advertising ABR belong too.
Here's an example of the command prompt and the correct syntax for the command:
Router(config-router)#area area-id range ipv6-prefix /prefix-length [advertise | not-advertise] [cost cost]
Now, in order to remove the specified area from the software configuration on an ABR, use the no area area-id command (with no other keywords). Like you see in the example below:
Router(config-router)#no area 1
Remember, when using the no area area-id command, the command removes all area options, such as area default-cost, area nssa, area range, area stub, and area virtual-link.
The "area range" command Keywords and Arguments Explained
area-id - This argument is an identifier of the area for which routes are to be summarized. The identifier can be specified as either a decimal value or an IPv6 prefix.
ipv6-prefix -This argument is (represents) the IPv6 prefix.
/prefix-length - This argument is (represents) the IPv6 prefix length.
advertise - This optional keyword sets the address range status to advertise and generates a Type 3 summary link-state advertisement (LSA).
not-advertise - This optional keyword sets the address range status to Do Not Advertise. This means the
Type 3 summary LSA is suppressed, and the component networks remain hidden from other networks.
cost - This optional keyword represents the metric or cost for the summary route, which is used during OSPF SPF calculation to determine the shortest paths to the destination. The value can be 0 to 16777215.
I hope this article was very informative and helped you quickly understand the usage, keywords, and arguments of the "area range" command. If you need to learn more about the command; I suggest you visit my website, were you'll find the latest information regarding Cisco IPv6 Design and Implementation Techniques.
OSPF COMMANDS IN IPv6 :
Router(config)# ipv6 router ospf Router(config-rtr)# router-ID
Router(config-rtr)# area <v4areaID> range
Router(config)# interface ethernet 0
Router(config-if)# ipv6 ospf area
Router(config-rtr)# redistribute [bgp | isis | rip | static]
OSPF SHOW COMMANDS:
show ipv6 ospf database
show ipv6 ospf database link show ipv6 ospf database prefix show ipv6 ospf route ospf
OSPF DEBUG COMMANDS:
OSPF EXAMPLE:
interface Ethernet 0
ipv6 address 2001:100:1::1/64
ipv6 enable
ipv6 ospf 100 area 0
interface Ethernet 1
ipv6 address 2001:200:2::1/64
ipv6 enable
ipv6 ospf 100 area 1
ipv6 router ospf 100
router-id 10.1.1.1
area 1 range 2001:200:FFFF:1::1/64
EIGRP COMMANDS:
interface FastEthernet 0/0
ipv6 enable
ipv6 eigrp 10
ipv6 bandwidth-percent eigrp ipv6 summary-address eigrp [admin-distance] ipv6 authentication mode eigrp md5 ipv6 authentication key-chain eigrp !
ipv6 router eigrp 10
router-id 10.1.1.1
stub [receive-only | connected | static | summary | redistributed]
log-neighbor-changes
log-neighbor-warnings [seconds]
metric weights tos k1 k2 k3 k4 k5
!
show ipv6 eigrp interfaces
show ipv6 eigrp neighbors detail
show ipv6 eigrp topology
show ipv6 eigrp traffic
clear ipv6 eigrp [as-number] [neighbor [ipv6-address | interface-type interface-number]]
debug eigrp fsm
debug eigrp neighbor [siatimer] [static]
debug eigrp packet
debug eigrp transmit [ack] [build] [detail] [link] [packetize] [peerdown] [sia] [startup] [strange]
debug ipv6 eigrp [as-number] [neighbor ipv6-address | notification | summary]
BGP4+ COMMANDS:
ENABLE BGP-4 ON THE ROUTER:
router bgp <ASN>
TURNS OFF BGP IPV4 PEERING
no bgp default ipv4 unicast
ESTABLISH A BGP4+ NEIGHBOR:
neighbor remote-as <ASN>
neighbor update-source
neighbor soft-reconfiguration inbound
ADDRESS FAMILIES:
address-family ipv6 unicast …
neighbor activate
exit-address-family
TO ENABLE A PREFIX-LIST FOR A BGP-PEER:
neighbor prefix-list [in | out]
ipv6 prefix-list [ seq [#] ] [ permit | deny ] [ ge ] [ le ]
ROUTE MAPS:
neighbor route-map [in|out]
route-map [ permit | deny ]
match ipv6 [ | next-hop | route-source] prefix-list set ipv6 next-hop
set local-pref 120
REDISTRIBUTION:
redistribute [bgp | connected | isis | ospf | rip | static] [metric ] [route-map ]
BGP4+ SHOW COMMANDS:
show ipv6 route bgp
show ipv6 neighbors
show bgp neighbors
show bgp ipv6 [summary]
show bgp ipv6 [ | community | community-list | dampened-paths | regexp | summary ]
show ipv6 prefix-list [summary | detail]
BGP4+ DEBUG COMMANDS:
debug bgp ipv6
clear bgp ipv6 [ * | ASN | | dampening | external | flap-statistics | ]
BGP4+ EXAMPLE:
interface Ethernet0
ipv6 address 5f00:0100:0:0:1::1 80
!
router bgp 100
no bgp default ipv4-unicast
neighbor 5f00:0100:0:0:2::1 remote-as 101
aggregate-address 2001:420:2000::/42 summary-only
!
address-family ipv6
neighbor 5f00:0100:0:0:2::1 activate
neighbor 5f00:0100:0:0:2::1 prefix-list bgp-in in
neighbor 5f00:0100:0:0:2::1 prefix-list aggregate out
network 5f00:0100:0:0:1::/40
exit-address-family
ipv6 prefix-list aggregate seq 5 deny 3FFE:C00::/24 ge 25
ipv6 prefix-list aggregate seq 10 permit ::/0 le 48
!
ipv6 prefix-list bgp-in seq 5 deny 5F00::/8 le 128
ipv6 prefix-list bgp-in seq 10 deny ::/0
ipv6 prefix-list bgp-in seq 15 deny ::/1
ipv6 prefix-list bgp-in seq 20 deny ::/2
ipv6 prefix-list bgp-in seq 25 deny ::/3 ge 4
ipv6 prefix-list bgp-in seq 30 permit ::/0 le 128
IPV6 ACCESS CONTROL LISTS:
ipv6 access-list [permit|deny] | any | host … | any | host … [log | log-input]
ipv6 access-list BLAH deny fec0:0:0:2::/64 * any
ipv6 access-list BLAH permit any
APPLY ACL TO AN INTERFACE:
Router(config-if)# ipv6 traffic-filter <ACL-NAME> [in | out]
For 6Bone – minimum prefix to announce:
3ffe::/16
3ffe:0800::/28
2000::/3 - 6to4
For 6Bone – prohibits advertisements of these:
fe80::/10 - link local
fec0::/10 - site local
::1/128 - loopback
::0/128 - default route
ff00::/8 - multicast
::/96 - ipv4 compatible addresses
::ffff/96 - ipv4 mapped addresses
View the ACLs:
show ipv6 access-list <ACL-MANE>
clear ipv6 access-list <ACL-NAME>
debug ipv6 packet [access-list <ACL-NAME>] [detail]
CONFIGURED TUNNEL ROUTER COMMANDS:
Router 1:
interface tunnel 0
ipv6 address 3ffe:b00:c18:1::3/27
tunnel source 192.168.1.1
tunnel destination 192.168.2.1
tunnel mode ipv6ip [auto-tunnel]
AUTO-TUNNEL IF USED FOR AUTOMATIC TUNNELS
Router 2:
interface tunnel 0
ipv6 address 3ffe:b00:c18:1::2/27
tunnel source 192.168.2.1
tunnel destination 192.168.1.1
tunnel mode ipv6ip [auto-tunnel]
6TO4 TUNNEL ROUTER COMMANDS:
Router 1:
interface Ethernet 0
ip address 192.168.1.1 255.255.255.0
ipv6 address 2002:c0a8:0101:1::/64 eui-64
interface tunnel 0
no ip address
ipv6 unnumbered Ethernet 0
tunnel source Ethernet 0
tunnel destination 192.168.2.1
tunnel mode ipv6ip 6to4
Router 2:
interface Ethernet 0
ip address 192.168.2.1 255.255.255.0
ipv6 address 2002:c0a8:0201:1::/64 eui-64
interface tunnel 0
no ip address
ipv6 unnumbered Ethernet 0
tunnel source Ethernet 0
tunnel destination 192.168.2.1
tunnel mode ipv6ip 6to4
For a 6to4 Relay add the following route:
ipv6 route ::/0
2 ROUTER EXAMPLE:
hostname Alpha
ipv6 unicast-routing
interface Ethernet0
description connected to A-LAN
no ip address
no ip directed-broadcast
ipv6 enable
ipv6 address FEC0::C0A8:20C1/123
ipv6 nd ra-interval 20
ipv6 nd ra-lifetime 180
ipv6 rip brest-lab enable
interface Serial1
description connected to Chi Ser1
bandwidth 4000000
no ip address
no ip directed-broadcast
encapsulation ppp
ipv6 enable
ipv6 address FEC0::C0A8:2025/126
ipv6 nd ra-interval 20
ipv6 nd ra-lifetime 180
ipv6 nd prefix-advertisement FEC0::C0A8:20C0/123 0 0 autoconfig
no suppress-ra
ipv6 rip brest-lab enable
clockrate 4000000
hostname Chi
ipv6 unicast-routing
interface Ethernet0
description connected to Core-LAN
no ip address
no ip directed-broadcast
ipv6 enable
ipv6 address FEC0::C0A8:10C2/123
ipv6 nd ra-interval 20
ipv6 nd ra-lifetime 180
ipv6 rip brest-lab enable
interface Serial1
description connected to Alpha Ser1
bandwidth 4000000
no ip address
no ip directed-broadcast
encapsulation ppp
ipv6 enable
ipv6 address FEC0::C0A8:2026/126
ipv6 nd ra-interval 20
ipv6 nd ra-lifetime 180
ipv6 nd prefix-advertisement FEC0::C0A8:10C0/123 0 0 autoconfig
no suppress-ra
ipv6 rip brest-lab enable
This Article Written Author By: Premakumar Thevathasan. CCNA, CCNP, CCIP, MCSA, MCSE, MCSA - MSG, CIW Security Analyst, CompTIA Certified A+.
.
No comments:
Post a Comment